Forum CDRinfo.pl

Forum CDRinfo.pl (https://forum.cdrinfo.pl/)
-   Homebrew (https://forum.cdrinfo.pl/f106/)
-   -   AIO Project, czyli płyta ze wszystkimi programami dla PS2 (https://forum.cdrinfo.pl/f106/aio-project-czyli-plyta-ze-wszystkimi-programami-dla-ps2-93698/)

A youkai of love 25.10.2017 19:20

Nie wiem o czym piszesz, nie śledziłem POPSa aż tak dokładnie ale wiem że mamy 2 wersje główne OPL, oficjelna i Daily Builds które na sztywno wspierają POPSa z tym ichnim ELM menu.

Berion 25.10.2017 19:28

Ok, to wiele wyjaśnia. Czyli Daily Builds to jest taki "custom OPL" Jay-Jay'a?

A youkai of love 25.10.2017 19:32

Tak, jak ktoś ma faze to używa tej z ELM menu, poza tym, kompatybilność ta sama, od miesięcy używam tej 2giej oficjelnej z ELM menu i szczerze to bardziej mi się podoba, lepiej mieć jak nie, zwłaszcza, że funkcjonalność nie traci. XD

Iskander 26.10.2017 17:20

Nie chcę robić jakiejś burzy, ale ten Jay-Jay to jest jakiś nie teges. Zaczęło się to od momentu jak sobie ubzdurał ten śmieszny ELF Loader (wtedy jeszcze POPS Loader, na co nie zgodził się kHn). Nie spotkał się z aprobatą teamu stojącego za OPL, więc zaczął tworzyć te swoje, o zgrozo, Daily Builds. Generalnie to jest syf i często koliduje ze zmianami w "prawdziwym" OPLu:

https://github.com/ifcaro/Open-PS2-L...ment-321077438

Nic dziwnego, że programiści nie są nastawieni do niego pozytywnie, a kHn zwinął projekt w dużej mierze przez ten cyrk. Sam gość też jest krzywy:

https://assemblergames.com/threads/p...10#post-951598

Brak wsparcia OPL w prototypach powstał na początku z prostego powodu - aby zablokować zwykłym użytkownikom korzystanie z niestabilnych wersji. Koniec końców blokada pozostała w ostatecznej wersji, a Jay-Jay pewnie ostro pracuje nad kolejnym projektem, aby ją obejść. :rotfl:


Fenomen całej sytuacji jest taki, że ten badziew, mam na myśli ELF Loader, niczym się nie różni od menu APPS, jest ułomny w zarządzaniu, a tyle hałasu o niego. :D Możliwe, że napisanie czegoś porządnego przerasta możliwości tego gościa, co by mnie nie dziwiło.

Berion 26.10.2017 18:55

Ma tzw. parcie na szkło. ;) Był jeszcze jeden taki, tylko gorszy. Nie pamiętam nicku, ale zapamiętałem go bo wygłaszał tyrady na temat mojego logo, jak bardzo jest gówniane (i to stare a la Amiga i to nowe, podczas gdy to Jay-Jay'owe jest trochę... nom, dziwne). ;p

PS: Ja ten OPL DB i skrypt Poof Project dodałem do AIO 1.51. W końcu to nadal część sceny. A POPSy zastąpiłem ostatnią wersją RIP.

Jolek 26.10.2017 19:46

@Iskander wielkie dzięki za streszczenie całej sytuacji.

Ja dodam od siebie, że blokada dla OPL była nie tylko po to aby
zablokować zwykłym użytkownikom korzystanie z niestabilnych wersji:
http://www.psx-place.com/threads/ope...e-4#post-84429.

Ale aby zablokować problematyczność z POPSem i jego legalnością:
Cytat:

Adding POPStarter to OPL also involves illegally downloading POPS to be able to enjoy this feature. From the moment it becomes an "official" feature (dedicated POPStarter page), it becomes problematic.
Tu jest to lepiej napisane (niestety przetłumaczone z FR na EN):
https://translate.googleusercontent....Fw#post1771270.

BTW również jak ktoś chce to polecam przeczytanie
4 posta (i następnych) poprzedniego linku i rozwinięcie spoilera (Voir).
Ma to związek z obecną stagnacją OPL.

Obejście tej blokady jest i to nawet w wersji v4. https://s3.postimg.org/9dl7d0wpf/8d2ad9671de3.jpg

@Berion jak tam pomysł z ISO9660?

Berion 26.10.2017 20:44

Od Google Translate w tłumaczeniach kontekstowych o dziwo lepszy jest https://www.deepl.com/translator

Jeszcze nie sprawdzałem, wypadło mi parę spraw które muszę zrobić. A jak siądę do tego to zmarnuję ze dwa wieczory pewnie. ;]

Tak sobie myślę, czy by nie przesunąć POPStartera z emulatorów (bo nim nie jest) do "game loaders".

Iskander 26.10.2017 20:50

Ale blokada OPL DB była wprowadzona w nowych prototypach z tego roku. A nie sprzed dwóch lat, kiedy ta cała drama się zaczęła. Zgoda, że kwestia legalności była kluczowa (i nadal jest). No, nie ważne to już jest teraz. :D Tak czy inaczej, tutaj jest link do zawsze najnowszej oficjalnej wersji beta OPL:
http://psx-scene.com/forums/f150/ope...leases-156209/

Berion 27.10.2017 18:55

@Fera2
Dodałem Cię do readme.

Linux Mint montuje Joliet, nie UDF. :| I tak samo Ubuntu wszelakie, tyle że obsługa tego Joliet to tylko lv1 i lv2, bez lvx, którego używam. Stąd error w starych distro, a w nowych po prostu nie montuje wcale. Jeszcze sprawdzę na PS2 czy uLE widzi lvx czy nie (ale skoro PS2Indent wam się nie ładuje to pewnie nie). Jeśli tak, to zostawię jak jest (pewnego dnia Linuksy może się nauczą, że UDF jest teraz standardem... :P) i dodam po prostu skrypt sh, który wymusza montaż jako udf (jakie to Linuksowe...).

Można więc tak się biczować: :sciana:
Kod:

mount -t udf -o loop,ro,unhide,uid=$(id -u) $home/aio.iso $home/udf
Pozostaje kwestia Japcoków, niestety nie mam dostępu do żadnego, ale sądzę że o ile pozwala zamontować obraz *.iso to sięgnie po UDF, a nie Joliet (gdyby Ci się chciało M@X to jeśli w katalogu głównym znajdziesz plik "RELINK.UDF" to znaczy, że jest ok, a jeśli zamiast niego będzie SYSTEM.CNF to znaczy że jest to zacofany OS ;}).

Jolek 27.10.2017 21:51

Montowanie, montowaniem ale czy na nagranych płytach też może być z tym problem (UDF)?

Berion 28.10.2017 00:40

Oczywiście. ;)

Dobra, Joliet jest lv2 bo widzę, że uLE też nie widzi. Obraz się montuje.

Jest jedna łyżka dziegciu: nie ma polskich znaków... Z jakiegoś powodu są tylko w Joliet na Windows, a w pozostałych nie ma... Widzi za to poprawnie znaki IsoBuster (wszędzie) i wszystkie pliki i foldery, czego nie można powiedzieć o np. DaemonTools. Myślałem, że ImgBurn robi sieczkę, ale w hex edytorze kodowanie się zgadza. Wygląda więc na to, że wszyscy mają w dupie poprawną implementację...

Ze zmian: przeniosłem tłumaczenia poziom wyżej, usunąłem dwa duplikaty które jakimś cudem nie zauważyłem i skróciłem nazwy tych plików.

Wersja 1.5.1 jest gotowa, jutro postaram się wrzucić na serwer zastępując 1.5.0.

Jolek 28.10.2017 12:27

Coś mi się wydaję, że będzie jeszcze 1.5.2.
Nie dam ci tak łatwo odejść. https://s3.postimg.org/9dl7d0wpf/8d2ad9671de3.jpg

Jak dasz radę wrzucić do niedzieli do 14.00 to chętnie sprawdzę,
później niestety lipa.
Dopiero w czwartek coś wygospodaruje.

Berion 28.10.2017 13:47

Nie dam rady, nie przy uploadzie ~100KB/s. :szczerb: A nie zostawiam włączonych komputerów bez nadzoru, tym bardziej na noc.

Także AIO v1.5.1 to już oficjalny i ostateczny release (też podzieliłem na pięć części po 512MB). Jest w porządku (ale o tej cholernej kropce w HDL to zapomniałem...).

Jolek 02.11.2017 23:18

Ilość załączników: 3
Teoretycznie wersji 1.5.2 nie będzie, ale... znalazłem trochę nowszych programów, gier i coś nowego\innego.

PS2DOSbox:
http://psx-scene.com/forums/f19/%5Bp...ml#post1186013.

Nie jest to jakiś super port, ale zawsze można spróbować (większość starych gier nie działa płynnie).
Emulator powinien "ogarnąć" klawiaturę USB (nie wiem czy wszystkie działają, ale z moją nie było problemu).

Można dodać do "dosbox.conf"
Kod:

mount c mass:[nazwa katalogu]
C:
dir /w

aby zamontować nasz dysk przenośny.
Np:
Kod:

mount c mass:StareGry
C:
dir /w

Znalazłem nowszą wersje lenschangera (1.2b):
http://www.ps2-home.com/forum/viewtopic.php?t=2066.

Miałem problem z odpaleniem lenschangera 1.2b bezpośrednio z instalatora,
więc dorzucam dodatkowo wersję DEV i SMBOOT.
Odpalając poprzez wLe nie ma różnicy którą "wersje" wybierzemy.

Geotron v0.5 (zamiast 0.3):
http://jum.pdroms.de/PS2/ps2prog.html.

PS2DOOM 1.0.5.0 (zamiast 1.0.2.2)
https://ps2homebrewing.wordpress.com...doom-v1-0-5-0/.

Pintor:
http://www.psx-place.com/resources/pintor.421/.

Balion:
http://www.psx-place.com/resources/ballion-ps2.411/.

Space Invaders for PS2:
http://www.psx-place.com/resources/s...s-for-ps2.430/.

Reszta gier powinna być tu:
http://www.psx-place.com/resources/c...brew-games.22/.

Czy TempGBA i ReGBA to wersje z 24-06-2017:
https://forum.cdrinfo.pl/f106/ps2-gp...0/#post1386751.
Coś mi wyskakuje jak wezmę właściwości 6.05.2015?

Niestety podobno mam płyty słabej jakości (Verbatim MCC 03RG20),
więc nadal mam "disk cannot be read" w moich PS2, kiedy próbuje odpalić AIO 1.5.1.

I tak mała pierdoła z "readme (for SNES-Station v0.2.4S).txt".
Najnowsza wersja to ta z 2016/06/09, nie z 2016/05/09.
Tu jest changelog do tej wersji:
http://psx-scene.com/forums/f19/unof...ml#post1207800.


Ogólnie to wielkie dzięki za ten projekt.

Meanthord 02.11.2017 23:19

I co Ty na to Berion? :P


Wszystkie czasy w strefie CET. Aktualna godzina: 19:16.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.