Powrót   Forum CDRinfo.pl > >

DVD-Video Tematy poświęcone kopiowaniu, edycji, konwersji i kompresji z/do formatu DVD



Witaj Nieznajomy! Zaloguj się lub Zarejestruj

Zarejestrowani użytkownicy mają dostęp do dodatkowych opcji, lepszej wyszukiwarki oraz mniejszej ilości reklam. Rejestracja jest całkowicie darmowa!

Odpowiedz na post
 
Opcje związane z dyskusją Ocena dyskusji Tryby wyświetlania
Stary 11.05.2005, 22:07   #1
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Authoring DVD - problem z dźwiękiem

Witam ...

Mam problem, który dręczy mnie od długiego czasu i nie mogę go rozwiązać (a próbowałem wiele razy i na wiele sposobów). A mianowicie:
-zgrywam film na kompa za pomocą karty TV Leadtek Winfast PVR2000 do formatu Mpeg2 PAL (karta ta wyposażona jest w sprzętowy kodek Mpeg2, a co za tym idzie koduje w "locie" i bez straconych klatek)
- do karty dodano oprogramowanie Ulead Video Studio 8 SE, w którym "przycinam" materiał filmowy wraz z audio i otrzymuję końcowy materiał w postaci Mpeg2 (audio+video)
- ponadto dołączono program Ulead DVD Movie Factory 3 SE, w którym authoringuję plik Mpeg2 do formatu DVD (ifo+vob)

I tu pojawia się problem: plik Mpeg2 nie wykazuje żadnych błędów (sprawdzany), a materiał DVD ma błąd synchronizacji audio do video (im dłuższy film tym większe opóźnienie audio do video).
Przeczytałem wiele postów dot. authoringu i obróbki video i audio. Starałem się sam znaleźć rozwiązanie, ale nadal bez efektu. Przypuszczam, iż robię gdzieś mały błąd, który wpływa na tak nieszczęśliwy wynik końcowy.
Próbowałem różnych rozwiązań i różnego oprogramowania (oprócz Ulead również DVDLab, Nero Vision Express i inne, oraz dodatkowe "wyspecjalizowane" typu BeSeet) i otrzymywałem ten sam efekt. Co gorsza błąd pojawia się na dwóch różnych komputerach z innymi systemami.

Co począć z tym diabelstwem

Oto konfiguracje komputerów:
- PIERWSZY: AMD Athlon XP 2800+; 512 MB DDR 400; Creative GeForce 32 MB AGPx4; Płyta DFI AD77 KT 400; Sound Blaster Live! 5.1; HDD Seagate 160GB Ata 100;
- DRUGI: AMD Sempron 2500+; 512 MB DDR 400 (dual channel); płyata Abit NF7 N-Force2 (+sound); Gigabyte NVidia GF 6600 AGPx8; HDD Seagate 120GB Ata100;

ps. Przepraszam Moderatorów za podobny do poprzednich moich postów, ale nie mam odpowiedzi na nie i starałem się w tym poście zaktualizować moje dane oraz doświadczenia oraz uzyskać (może) odpowiedź (rónież od nich) - wszelkie pomysły mile widziane ...
trytco jest offline   Odpowiedz cytując ten post

  #ads
CDRinfo.pl
Reklamowiec
 
 
 
Data rejestracji: 29.12.2008
Lokalizacja: Sieć globalna
Wiek: 31
Posty: 1227
 

CDRinfo.pl is online  
Stary 12.05.2005, 11:08   #2
1stwasp
Redakcja
 
Avatar użytkownika 1stwasp
 
Data rejestracji: 27.12.2003
Lokalizacja: Wrocław
Posty: 719
1stwasp zaczyna zdobywać reputację <1 - 49 pkt>
Tak... plik MPEG2 zawierający audio i video to jest MPEG2 PS (Program Stream).
Jak zapewne wiesz lub nie do authoringu wprowadza się plik MPEG2 ES (Elementary Stream) + osobne audio - zgodne ze specyfikacją DVD Video - MPEG2 audio z grubsza zgodne jest :-)

Rózni sie to tym, że w PS audio i video ma takze dane opakowujące to w jeden strumień. Teraz aplikacja do authoringu dodaje drugie opakowanie i pewnie gdzieś się rozjeżdża synchronizacja... ES to osobny srtumień tylko video...

jak juz tu kiedys pisałem, zadna szanująca się aplikacja do authoringu nie powinna akceptować plików PS. Robią to wszelakiego rodzaju kombajny i DVD Lab Pro(totyp).

Efekty są ogólnie znane - z jednym mamy do czynienia w Twoim poście.

Pozdrawiam!
1stwasp jest offline   Odpowiedz cytując ten post
Stary 12.05.2005, 11:53   #3
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Czyli twoim zdaniem 1stwasp dwukrotna obróbka tego samego materiału powoduje rozjazd synchronizacji. Próbowałem już rozbijać materiał na osobny strumień (audio i video) i tak spreparowany poddawać authoringowi.Robiłem to w DVDLab, który sam proponuje takie rozwiązanie. Ale efekt zawsze taki sam.
Próbowałem również w BeSweet poustawiać parametry dźwięku, ale to również lipa ...

Co w takim razie mam począć? Proszę o jakieś wskazówki ...
trytco jest offline   Odpowiedz cytując ten post
Stary 12.05.2005, 12:07   #4
1stwasp
Redakcja
 
Avatar użytkownika 1stwasp
 
Data rejestracji: 27.12.2003
Lokalizacja: Wrocław
Posty: 719
1stwasp zaczyna zdobywać reputację <1 - 49 pkt>
Nie tyle dwukrotna tylko, ze sa takie programy do "authoringu", ktore przyjma strumien PS cos go tam rozmuksuja na kolanie i go opakietuja jako DVD Video i wtedy moga byc takie klopoty, nawet obraz moze drżeć po czymś takim...

Powiedz mi tak - o ile dokładnie rozjeżdza sie ten dźwięk na godzine materiału i jaki to jest dźwięk (AC3, MPEG2 audio) - i czy jest 48kHz??.
Podaj mi rowniez srednia bitowa przeplywnosc Twojego video i audio (razem lub osobno tylko wyraznie).

Poza tym czy w masz w karcie ustawione odpowiednie parametry MPEG2 - kolejnosc pol, GOP, itp.

Spróbuj może przechwycic to jako zwykłe AVI i przekodować jakimś koderem softwareowym - nawet kawałek, tylko żaby zobaczyc czy efekt będzie ten sam...

Jak juz to wszystko sprawdzisz i nie zadziala to daj znac, bedziemy dalej myslec :-)

Pozdrawiam!
1stwasp jest offline   Odpowiedz cytując ten post
Stary 12.05.2005, 12:58   #5
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Dźwięk rozjeżdża się stopniowo i po 1h35min dochodzi do niecałych 2 sekund poślizgu. Format audio to mpeg2 (48Khz, 224 kbps, stereo), ale próbowałem również z wav (48kHz, 1536 kbps, stereo). Też się rozjeżdża.
Video nagrywałem w 8000, 6000 i 4000 kbps poczynając od największej. Myślałem, iż mój sprzęt nie potrafi przetworzyć takiego strumienia dlatego zmniejszałem.
Do video w DVDLab używałem narzędzia "Rewrite GOP Timecode" i nawet przesuwałem audio do video o -500ms (tak trzeba było robić dla kart sound blaster w obróbce divx). Strumień audio i wideo mają dokładnie taką samą długość.

I wszystko to, to lipa ...

Wieczorem nagram coś do avi, bez kompresji i skompresuję tak jak napisałeś (softwerowym kodekiem) i jak to zrobię to dam znać o efekcie...

Pozdrawiam i dzięki za pomoc ...
trytco jest offline   Odpowiedz cytując ten post
Stary 13.05.2005, 01:00   #6
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Tak jak napisałem, tak zrobiłem ...
Zgrałem materiał (około 2 godzinny) do mpeg2 softwarowego i wszystko było ok z plikiem wynikowym. Materiał zostawiłem bez montażu. Idąc twoim tokiem rozumowania, 1stwasp założyłem, że najprostsze nawet cięcie w Ulead pogorszy sprawę. Po authoringu marność.
Authoring powtórzyłem w DVD-Lab,Ulead Video Studio (moduł do tworzenia DVD) oraz Ulead Movie Factory, zarówno stosując materiał "scalony" i "rozbity" na audio i video. W DVD-Lab sprawdziłem GOP (był bez błędów). Ponadto raz używałem audio jako mpa, a drugi jako wav (parametry jak w poprzednim poście).
Wszystkie te operacje nic nie dały. Jakieś nowe pomysły ( ), bo ja zaczynam myśleć, iż jest to jednak wina sprzętu ...

Pozdrawiam
trytco jest offline   Odpowiedz cytując ten post
Stary 15.05.2005, 07:47   #7
Agaitom
Bywalec
 
Data rejestracji: 26.02.2004
Posty: 26
Agaitom w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Mam tę samą kartę tv i ten sam problem, szukałem wszędzie ale nie otrzymałem odpowiedzi. Dźwięk się rozjeżdża i tyle. Zostało mi nagrywanie z vhs-u przez kabel antenowy, innego wyjścia chyba nie ma. Podejrzewam, że przyczyną rozjeżdżania się dźwięku jest różnica w pracy karty tv i karty muzycznej. Tam powstaje opóźnienie. Co ciekawe sprawdzałem długości plików w minutach i video oraz audio -mają taką samą a dźwięk się rozjeżdża. Ja już zgłupiałem i sobie odpuszczam zgrywanie tym sposobem. Pozdrowienia w niedoli.
Agaitom jest offline   Odpowiedz cytując ten post
Stary 15.05.2005, 14:59   #8
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Witam Agaitom ...
Jak już wcześniej napisałem, próbowałem prawie wszystkiego, ale ja nie poddaję się. W ostatnich dniach również doszedłem do podobnego wniosku (sprawdzałem również podobne posty na forum Ulead). I tu pojawia się światełko w tunelu !!! Jeżeli jest to opóźnienie sprzętowe, to trzeba spróbować przyciąć ścieżkę audio o kilka, kilkanaście milisekund na jej początku (lub więcej, ale mniej niż 200 ms). Nie wpłynie to wyczuwalnie na przyspieszenie dźwięku na początku filmu, a poprawi synchronizację. Dlaczego tak się dzieje to nie wiem, ale gdy kiedyś przerabiałem nagrany materiał na divx to skutkowało. Przypuszczam, iż trzeba znaleźć metodą prób i błędów to przesunięcie i stosować do pozostałych nagrań. W chwili, kiedy piszę tego posta nie mam jeszcze 100% pewności, ale zacząłem pierwsze próby z programem Cuttermaran, który pozwala zczytać dokładną długość ścieżek (audio i video) co do ms. Można również w nim załączyć preview mixujące w czasie rzeczywistym te dwie ścieżki. Pierwsze próby są dość obiecujące, jednak nie miałem czasu wykonać authoryzacji materiału do DVD. Jak tylko coś osiągnę (dobrego lub złego) powiadomię w kolejnym poście.

Pozdrawiam
trytco jest offline   Odpowiedz cytując ten post
Stary 15.05.2005, 20:43   #9
ikar39
Stały bywalec ;)
 
Avatar użytkownika ikar39
 
Data rejestracji: 13.01.2004
Lokalizacja: poznań
Posty: 156
ikar39 zaczyna zdobywać reputację <1 - 49 pkt>
-

nigdy sie nie koduje w locie lepiej zgrac czysty format np avi i pózniej sie pobawic ja tak robie i jest wszystko ok
ikar39 jest offline   Odpowiedz cytując ten post
Stary 15.05.2005, 21:57   #10
1stwasp
Redakcja
 
Avatar użytkownika 1stwasp
 
Data rejestracji: 27.12.2003
Lokalizacja: Wrocław
Posty: 719
1stwasp zaczyna zdobywać reputację <1 - 49 pkt>
Jeszcze jedno... spróbuj te pliki wczytać do Scenarista i tam zobaczyć po pierwsze - czy się wczytują, po drugie czy nie raportują błędów, po trzecie czy się multipleksują.

Dziwi mnie w tym jedna rzecz - jak zgrasz MPEG2 i jego odłuchasz przed authoringiem to jest OK - tak, czy nie??

Jeżeli jest OK i rozjeżdża się podczas authoringu to coś jest nie tak.
Inną sprawą jest, że ramki audio i video nie mają tej samej długości. Ramki MPEG audio mają 32ms, video 40ms. Synchronizację ramek audio uzyskujemy co 8 ramek video (wtedy opóźnienie audio - video co 8 ramkę wynosi 0ms).

Jeżeli z jakiś powodów (sprzętowych??) gubi się to synchro, dźwięk może się teoretycznie stopniowo rozjeżdżać, ale kurcza, dziwi mnie to conieco...

Proponuję jeszcze potraktować to Scenaristem - uznajmy go za wyrocznię.
Jak się nie uda to oznacza, że coś się źle przechwytuje i dalej nie ma już co szukać, bo się tego dobrze zrobić nie da...

Pozdrawiam!
1stwasp jest offline   Odpowiedz cytując ten post
Stary 16.05.2005, 10:41   #11
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Cytat:
Napisany przez ikar39
nigdy sie nie koduje w locie lepiej zgrac czysty format np avi i pózniej sie pobawic ja tak robie i jest wszystko ok
Witam ikar39 ... problem tkwi w tym, iż po to kupowałem droższą kartę ze sprzętowym mpeg2, aby nie czekać godzinami na konwersję między formatami ...

Witam również 1stwasp ... spróbuję z tymi plikami w Scenarist i odezwę się co otrzymałem ...

Pozdrawiam
trytco jest offline   Odpowiedz cytując ten post
Stary 19.05.2005, 21:47   #12
trytco
Nowy na forum
 
Data rejestracji: 12.04.2005
Posty: 14
trytco w tym momencie nie ma Reputacji dodatnich ani ujemnych <0  pkt>
Witam ...



Myślę, iż ten post będzie dobrym podsumowaniem mojej walki z problemem authoryzacji i synchronizacji video i audio.

UDAŁO SIĘ !!!

Jak dotąd żaden z programów nie potrafił na moim sprzęcie (patrz post pierwszy) dobrze zgrać do DVD nagranego materiału (karta TV Leadtek PVR2000). Ale nie poddawałem się i z pomocą innych (wielkie dzięki) rozwiązałem ten problem. Droga eliminacji okazała sie najlepszą. Ale do rzeczy:
1) W odruchu rozpaczy zaglądnąłem na stronę http://www.leadtek.com.tw/eng/suppor...Fast%20PVR2000 i okazało się, że są na niej najnowsze drivery pod kartę tv (Leadtek PVR2000) - ściągnąłem i zainstalowałem.
2) Odinstalowałem sterowniki oraz oprogramowanie karty dźwiękowej (SB Live! Digital). Ponownie zainstalowałem same sterowniki tej karty, ale bez dodatków (mixer, piano itp). W "Panelu Sterowania >>> Dźwięk i Multimedia" w zakładce "Audio" ustawiłem pod odtwarzaniem i nagrywaniem dźwięku, zaawansowane, pełne wspomaganie sprzętowe oraz najlepszą jakość (zakładka "Wydajność").
3) Zainstalowałem "Mpeg2-VCR" (wersja trail - 14 dni) i tym programem srawdziłem GOP nagranych plików i ewentualnie poprawiłem.
4) W programie DVD Author (trial) zgrałem wszystko do DVD

I zadziałało ... Nie wiem dokładnie, który z tych trzech kroków okazał się "strzałem w dziesiątkę", ale zadziałało i to się liczy. Nie sprawdzałem jeszcze oprogramowania Ulead dołączonego do karty TV, ale wydaje mi się, że też będzie działać.

Jeszcze raz dziękuję wszystkim, którzy zabrali głos w dyskusji - w szczególności 1stwasp - dzięki niemu zacząłem szukać z latarką, a nie pod latarnią ...

Pozdrawiam ...
trytco jest offline   Odpowiedz cytując ten post
Stary 19.05.2005, 22:15   #13
ksviper
samotność
 
Avatar użytkownika ksviper
 
Data rejestracji: 08.08.2004
Lokalizacja: Klimontów
Posty: 2,940
ksviper po prostu jest dobry(a) <350 - 449 pkt>ksviper po prostu jest dobry(a) <350 - 449 pkt>ksviper po prostu jest dobry(a) <350 - 449 pkt>ksviper po prostu jest dobry(a) <350 - 449 pkt>ksviper po prostu jest dobry(a) <350 - 449 pkt>
Ja kodowałem do MPEG2 prosto z Adobe Premiere 6.5 wbudowanym kodekiem a potem do Ulead DVD Movie Factory 3 (pełna wersja a nie SE) i nie ma żadnych problemów, robiłem to wiele wiele razy i żadnych problemów. Przypuszczam że błąd mógł być po stronie sterowników do karty.
ksviper jest offline   Odpowiedz cytując ten post
Odpowiedz na post

Opcje związane z dyskusją
Tryby wyświetlania Oceń tę dyskusję
Oceń tę dyskusję:

Twoje uprawnienia:
Nie możesz rozpoczynać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz umieszczać załączników
Nie możesz edytować swoich postów

BB codeWłączone
EmotikonkiWłączone
Kody [IMG]Włączone
Kody HTML są Wyłączone

Teleport


Wszystkie czasy w strefie CET. Aktualna godzina: 06:03.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.